Brand Lift Dashboard Refresh Delays

Incident Report for Dynata Solutions

Update

We are continuing to work on a fix for this issue.
Posted Dec 15, 2025 - 05:15 EST

Identified

Dynata is observing delayed processing times for Brand Lift dashboard refreshes affecting a small subset of large, high-volume studies. For any study affected, all exposure and survey data continue to be collected as expected; the impact is limited to the timing of dashboard updates. Engineering has identified the contributing constraints and is deploying performance improvements designed to increase throughput and resiliency. Additional optimizations are scheduled to continue through the coming weeks.

Updates will be posted as enhancements progress.
Posted Dec 12, 2025 - 17:34 EST
This incident affects: Dynata+ Platform (Dynata+ BrandLift).